РАЗРАБОТКИ РЭА   |    CISCO  ]



    CISCO + 2 провайдера с резервированием


!
ip sla 1
 icmp-echo 212.100.111.241 source-interface FastEthernet0.2
 timeout 1000
 threshold 40
 frequency 3
ip sla schedule 1 life forever start-time now
ip sla 2
 icmp-echo 87.141.100.193 source-interface FastEthernet0.3
 timeout 1000
 threshold 40
 frequency 3
ip sla schedule 2 life forever start-time now
!
track 1 rtr 1 reachability
!
track 2 rtr 2 reachability
!
!
interface FastEthernet0.2
 encapsulation dot1Q 2
 ip address 212.100.111.251 255.255.255.240
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet0.3
 encapsulation dot1Q 3
 ip address 87.141.100.199 255.255.255.240
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet0.10
 encapsulation dot1Q 10
 ip address 213.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip policy route-map ISP1
!
interface FastEthernet0.20
 encapsulation dot1Q 20
 ip address 88.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip policy route-map ISP2
!
ip nat pool ISP1-pool 213.0.0.10 213.0.0.31 prefix-length 24
ip nat pool ISP2-pool 88.0.0.10 88.0.0.31 prefix-length 24
ip nat inside source route-map ISP1-NAT interface FastEthernet0.2 overload
ip nat inside source route-map ISP2-NAT interface FastEthernet0.3 overload
!
access-list 1 permit 213.0.0.0 0.0.0.255
access-list 2 permit 88.0.0.0 0.0.0.255
access-list 100 permit ip 88.0.0.0 0.0.0.255 213.0.0.0 0.0.0.255
access-list 100 permit ip 213.0.0.0 0.0.0.255 88.0.0.0 0.0.0.255
!
!
!
route-map ISP1-NAT permit 10
 match ip address 2
 match interface FastEthernet0.2
!
route-map ISP2-NAT permit 10
 match ip address 1
 match interface FastEthernet0.3
!
route-map ISP2 deny 10
 match ip address 100
!
route-map ISP2 permit 20
 match ip address 2
 set ip next-hop verify-availability 87.141.100.193 2 track 2
 set ip next-hop verify-availability 212.100.111.241 3 track 1
!
route-map ISP1 deny 10
 match ip address 100
!
route-map ISP1 permit 20
 match ip address 1
 set ip next-hop verify-availability 212.100.111.241 2 track 1
 set ip next-hop verify-availability 87.141.100.193 3 track 2
!
!
event manager applet CLEARNAT
 event track 1 state up
 action 1 cli command "clear ip nat translation *"
event manager applet CLEARNAT_2
 event track 2 state up
 action 1 cli command "clear ip nat translation *"
!