РАЗРАБОТКИ РЭА   |    CISCO  ]



    IPSec VPN туннель между двумя маршрутизаторами Cisco с использованием Profile


!
crypto isakmp policy 10
 encr aes 256
 authentication pre-share
 group 2
!
crypto isakmp key preshared_key address 10.0.0.6
!
crypto ipsec security-association lifetime seconds 10980
!
crypto ipsec transform-set AES256-SHA esp-aes 256 esp-sha-hmac
crypto ipsec df-bit clear
!
crypto ipsec profile Tunnel
 set security-association lifetime kilobytes 536870912
 set security-association lifetime seconds 3660
 set transform-set AES256-SHA
!
!
interface Tunnel0
 ip unnumbered FastEthernet0
 tunnel source FastEthernet0
 tunnel destination 10.0.0.6
 tunnel mode ipsec ipv4
 tunnel protection ipsec profile Tunnel
!
!
interface FastEthernet0
 ip address 10.0.0.1 255.255.255.0
 ip access-group Input-Traf1 in
 no ip proxy-arp
 duplex auto
 speed auto
 no cdp enable
!
!
!
ip route 192.168.0.0 255.255.0.0 Tunnel0 
ip route 0.0.0.0 0.0.0.0 10.0.0.2
!
ip access-list extended Input-Traf1
 permit esp any host 10.0.0.1
 permit udp any host 10.0.0.1 eq isakmp
 permit icmp any host 10.0.0.1
 deny   ip any any
!